ServiceDesk Configuration (pdm_configure) window does not load/populate

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Article ID: 36998

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Service Desk Manager Configuration window (pdm_configure) does not come up or populate when running the pdm_configure command or selecting Service Desk configuration from the Windows Menu.

Service Desk stdlog.x shows the below errors:

WARN ConfigUI.java 408 Failed to load config_jni library from path E:\PROGRA~1\CA\SERVIC~1\bin\config_jni.dll 

java.lang.UnsatisfiedLinkError: E:\Program Files\CA\Service Desk Manager\bin\config_jni.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

Cause

Service Desk Manager is a 32-bit application.

The Service Desk Manager configuration utility uses JRE 32-bit. If JRE 64-bit is installed, then the Service Desk configuration window will not be populated.

Environment

Service Desk Manager 12.9 and 14.1
All Supported Windows Operating Systems
64-bit JRE

Resolution

1. Run the below command on the command prompt of the Service Desk Manager server to identify the JRE version

java -version

2. If the output contains the string "Java HotSpot(TM) 64-Bit Server", then this indicates that JRE 64-bit is installed.

3. Bring up the Control Panel -> Open Programs & Features -> Uninstall JRE 64-bit.

4. Download JRE 1.7.0_51 32-bit (jre-7u51-windows-i586.exe) from the below link:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html#jre-7u51-oth-JPR

5. Create a folder "1.7.0_51" under C:\Program Files (x86)\CA\SC\JRE folder. This path may vary depending on where you installed CA Applications. 

6. Add JRE bin folder to the System Path by right-click on My Computer -> Properties -> Advanced System Settings -> Click on Environment Variables button -> In the System Variables section select Path and click the Edit button -> At the end of the Variable value field type a semi-colon (;) and enter the JRE/bin install path (i.e. C:\Program Files (x86)\CA\SC\JRE\1.7.0_10\bin).  Click OK -> Click OK in the Environment Variables window -> Click OK in the System Properties window.

7. Bring up the command prompt and run the command java -version. This should now display the correct JRE 32-bit Version without the text "64-Bit Server".

8. Run the command pdm_configure. This will bring up the Service Desk configuration window.