ConnectALL Automations will not run
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ConnectALL Automations will not run

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Article ID: 369900

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Updated On:

Products

ConnectALL

Issue/Introduction

Automations are not running or acquiring a lock.  The automation log file is repeating the following message every few seconds:

WARN  yyyy-MM-DD HH:mm:ss,SSS [<Automation Name> | <Automation Timestamp> |  | {<Project<}][(connectall-flows) thread #nnnn - Split] org.apache.activemq.artemis.core.client: AMQ212054: Destination address=writeQ is blocked. If the system is configured to block make sure you consume messages on this configuration.

 

Cause

This can be caused if disk space usage rises above the configured disk space threshold in the broker service; by default this is 90%.

Resolution

There are two options to resolve this. 

1) Clear disk space until the used space falls below 90%

 

2) Reconfigure the broker service disk threshold to a higher value

To do this, edit <CONNECTALL_HOME>/Broker/connectall-broker/etc/broker.xml

Locate the line that reads <max-disk-usage>90</max-disk-usage>

Change 90 to a higher value

Save and restart the broker service