Gen 8.6 Toolset 'Call REST' crashes when selecting json file
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Gen 8.6 Toolset 'Call REST' crashes when selecting json file

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Article ID: 369898

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Updated On:

Products

Gen - Workstation Toolset Gen

Issue/Introduction

Using the Gen 8.6 Toolset to add a 'Call REST' statement and the 'Upload OpenAPI File' Browse option to select a file via the 'Select OpenAPI Specification File" dialog.
After selecting the file, the toolset always crashes with no apparent error.

The Windows Event Viewer shows the following Application Error under 'Windows Logs > Application':
**********
Faulting application name: TOOLSET.EXE, version: 8.6.0.9233, time stamp: 0x62de3b4e
Faulting module name: KERNELBASE.dll, version: 10.0.19041.4412, time stamp: 0x6d8c3da8
Exception code: 0xc06d007f
Fault offset: 0x00140b82
Faulting process id: 0x4568
Faulting application start time: 0x01dabbaf1a9cee35
Faulting application path: C:\Program Files (x86)\CA\Gen86\gen\TOOLSET.EXE
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: ae584287-d2dd-4dbe-bdeb-617ebedc46d3
Faulting package full name:
Faulting package-relative application ID:
**********

The crash occurs trying to open any OpenAPI Specification File (*.json) from a new model or an existing model and also occurs when using the full path of the file in the 'OpenAPI Spec URI' field.
PTS WKS86200 and WKS86300 plus some later TSN863* PTFs (TSN86301, TSN86302, TSN86303, TSN86304, TSN86305) are installed.
All developers are experiencing the problem.

Environment

Release: 8.6
Component: Gen Workstation Toolset

Cause

Gen Support could not recreate the problem in-house.
The developers are using a custom install package from their Desktop Support team to install the base Gen product and required PTFs.

Resolution

After manually installing the base Gen 8.6 product and the same PTFs that are in the custom package the OpenAPI Specification File selection did not crash.
In summary there is no problem with the Gen Toolset and the custom install package must be not 100%.
The problem was referred to the Desktop Support team.

Additional Information