End point cannot be found in Identity Governance Connector creation

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Article ID: 36977

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Issue:

When creating a new connector and selecting connector server,all previously created endpoints are not visible.

 

Environment:

Connector server was installed using the Identity Governance installation media.

Identity Governance is 12.6.x

 

Cause:

This is usually the result of a corruption in the jdbm folder.

Usually this is also accompanied by errors in the jcs_daily log file:

2015-12-21 11:44:32,631 226162 [Timer-1] (com.ca.jcs.core:com.ca.jcs.standalone.StandaloneServerManager:1431) ERROR  - Failed to delete state from the JDBM partition: eTNamespaceName=Windows NT,dc=im,dc=etasa

javax.naming.NamingException: [email protected]_SERVERNAME: Failed to remove the entry from the connector configuration partition: eTNamespaceName=Windows NT,dc=im,dc=etasa 

The eurekify.log will show the following exception:

2015-12-21 11:57:49,926 WARN  [com.ca.iam.model.impl.IAMObjectImpl] (http-0.0.0.0-8080-3) Failed to load property 'namespaceNames' on object Domain=im,Server=Server

com.ca.iam.model.IAMPersistenceException: javax.naming.NamingException: [LDAP: error code 80 - code 80 (OTHER-NamingException): failed on search operation: dc=im,dc=etasa: java.io.EOFException: ]; remaining name 'dc=im,dc=etasa'

 

Resolution:

Shut down the JCS server

Backup folder ..\CA\RCM\Server\Connector Server\jcs\data\jdbm\etasa.

Remove all files from this folder.

Start the JCS server.

 

 

Environment

Release:
Component: SGRM