Cannot migrate the Kubernetes containers after an update as the migrate option doesn't appear after the VCSA
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Cannot migrate the Kubernetes containers after an update as the migrate option doesn't appear after the VCSA

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Article ID: 369727

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Customer isn't getting the Migrate option after the VCSA update. However, a fresh installation comes up with the Migrate option under "container volumes"

On vSphere Client, MIGRATE button is not there after a patch from VCSA 7.0u3j to  VCSA 7.0 u3p

However,  "MIGRATE" button comes up on vCSA 7.0 u3p fresh installation.

Environment

Standalone vCenter with Kubernetes

Cause

There are high chances that the plugin version is not updated and the vsphere-ui is unable to download the latest version out of the box.

Resolution

Try to clear the cached vSAN plugin and restart the vSphere-ui.

Here are the steps.

# Stop vSphere UI service
vmon-cli --stop vsphere-ui

# Clean the vSphere UI cache
rm -rf /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/*
rm -rf /usr/lib/vmware-vsphere-ui/server/work

# Start the vSphere UI service
vmon-cli --start vsphere-ui

# Reboot the vCenter
reboot -f

Additional Information

The plugin is not being automatically updated because the version of the plugin is not increased compared to the last that was already deployed in the customer's environment. This is not done automatically for patch releases and is missed in this case. So when the 2 plugins are compared the vSphere UI decides there is no change of the plugin and it's not updated.

Attachments

container volumes.jpg get_app