Upgrade fails at disk space check step - Aria Operations for Logs
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Upgrade fails at disk space check step - Aria Operations for Logs

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Article ID: 369646

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When trying to manually upgrade an Operations for Logs appliance, the upgrade will not proceed as the /storage/var partition is at full.

An error is returned at the disk space evaluation phase of the upgrade script.

Not enough disk space! Available disk space at /storage/var: {Total disk space available} is less than required disk space: {Total requires disk space}.

This can also be found in the "upgrade.log" found in "/storage/core/loginsight/var".

Environment

Aria Operations for Logs 8.12 upgrading to Aria Operations for Logs 8.14.1

Cause

A file,  "QueryResultsCache.data" in the "/storage/var/loginsight/cache" directory is 5+ GB.

This can be found by listing all files on the appliance;

cd /
du -h | sort -h

 

We can see above that 

/storage/var/loginsight/cache

Is over 5GB in size.

Resolution

  1. Change directory and list the files using the following commands:

    cd /storage/var/loginsight/cache
    ls -lh

    You should see the file "QueryResultsCache.data" with a size of multiple GB

  2. Stop the Operations for logs service, remove the file and start the service again using the following commands:

    service loginsight stop
    rm QueryResultsCache.data
    service loginsight start

  3. Continue the manual upgrade.

Additional Information

The 'DataResultsCache.data' file retains recent queries made in the UI and utilizes these results for subsequent similar queries.