Authorization Error 404 when accessing Operations manager plugin in vCloud DIrector
search cancel

Authorization Error 404 when accessing Operations manager plugin in vCloud DIrector

book

Article ID: 369639

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

vCloud Director Tenants have intermittent issues accessing Operations manager plugin.

When accessing the browser Dev Tools, In the Network tab on the browser we see 404 error for login as below:

 

Environment

Aria Operations: 8.12.1.21952151

VMware Chargeback: 8.10.1

Cause

Multiple old Tenant App plugins are present in vCloud Director. This can be confirmed with Step 4 in the Resolution below.

 

Resolution

  1. Take snapshot of your chargeback appliance in vcenter without memory.
  2. In chargeback UI go to Support and stop the vCD plugin.



  3. Go to vCD provider and disable and delete the Operations plugin from customize portal.
  4. in vCD API explorer for to external service and run the 'GET /extenstions/api'  API copy the response field in a notepad.



  5. Use the 'PUT /extenstions/api{id}' API to disable all plugins with TA extension in the name one by one change 'enabled=false' 



  6. Use the 'Delete /extenstions/api{id}'  API below to Delete all the TA extension plugins.
  7. Run the GET API from step 4 again and make sure no TA extension plugin is there anymore.
  8. Got to chargeback UI-> support page and and configure the plugin again.
  9. Enable the access for the tenants under access management.