UUJMA processes cau9clie.exe and cau9ctk.exe are missing
search cancel

UUJMA processes cau9clie.exe and cau9ctk.exe are missing

book

Article ID: 36962

calendar_today

Updated On:

Products

Unicenter Job Management Option

Issue/Introduction

After a reboot of the Unix server, jobs are no longer starting on the Universal Agent with messages telling the station is unavailable

The "unifstat" output shows that 2 components are missing (in bold)

Component Name Pid Status

------------------------------------ ------- --------------
../..

CA-Job Management Syscon Server 741 running

CA-Job Management 2.0 Job Server - not active

CA-Job Management 2.0 Event Mgr. - not active

CA-Job Management Event Logger 730 running

Environment

Unicenter 3.1 NSM (0703) on HP Unix

But it might happen on any Unix/Linux server with either UUJMA 3.1 or 11.2

Cause

When the  agent starts, it stores its process ids in files in directory $CAIGLBL0000/tmp.  After the reboot, these file descriptors got corrupted.

Resolution

  1.  Stop the agent with "unishutdown all "
  2.  Delete all the files from the "$CAIGLBL0000/tmp " directory
  3.  Delete all the files from $CAIGLBL0000/tmp/$HOST directory
  4.  Start the agent with 'unistart all' 


The Agent will be able to store its PIDs and message queue in the following files:

  • cau9en2.pid
  • cau9ctk.pid
  • cau9cli.pid
  • wmrsd.pid
  • cau9en2_1.msg