Aria Automation login prompts 'ERROR call to Directory Service Failed"
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Aria Automation login prompts 'ERROR call to Directory Service Failed"

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Article ID: 369607

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Unable to log in to Aria Automation and vIDM portals using LDAP users. 

Login screen prompts 'ERROR call to Directory Service Failed".

Environment

VMware Identity Manager 3.3.x

Cause

Active directory Integration inconsistent in vIDM.

  • Test Connection to AD fails from vIDM. 
  • Directory Sync fails with Error 'Response from connector: Failed to complete dry run'
  • vIDM is unable to connect to AD using the currently stored details.
    This could be because of changes such as:
    - Recent change of AD certificates
    - Change of password for user used to add AD credentials
    - Validate the Base DN used. 
    - Network isolations for AD.
  • VIDM connector.log shows Directory configuration validation failing with SSLHandshake errors similar to one of the following:


Resolution

  1. Test the Active Directory integration on vIDM:
    - validate credentials used
    - validate certificates 
    - validate Base DN used.
    - Test connectivity to AD from vIDM appliance - openssl / telnet.

  2. Once successful. Save the configurations and re-initiate Directory Sync and test login to portals using AD users.