Jobs failing with "SUBERROR"

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Article ID: 36960

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

Issue:

Jobs are failing with "SUBERROR" status


Environment:

Applies ONLY to Windows Agent Machines.


Cause:

When a Job is defined to execute under the authority of a USER Id;
- If the User is not able to successfully Authenticate with the credentials defined under Agent Topology
- Agent Event Viewer logs will report - "Logon failure: unknown user name or bad password"


Resolution:

1) Look for JOB definition for the USER Id defined?

2) Validate if the USER Id has its credentials correctly defined under Agent Topology.

3) To Update an Agent User Credentials follow these steps:

    a) Connect to the server as an administrator using CA WA Desktop Client.
        - Open the Admin perspective.
        - Right-click Topology in the Admin view, and select Open from the pop-up menu.

    b) The Topology view opens.
        - Right-click the agent name you want to change a user's password for, and select View Definition from the pop-up menu.

    c) The Properties tab of the Agent Definition view opens.
        - Select the Users tab.
        - Select the user, and click Change Password.

    d) The Change Password dialog opens.
        - Enter a new password, confirm it, and click OK.
        - Click the Save icon at the top right corner of the view.

  The agent's user's password is changed successfully..

Note: If the problem is intermittent, look out for Agent User profile if its designed to get LOCKED OUT for 5 minutes after certain number of incorrect attempts. If this is the case work with your local System Admin to disable Account LOCK feature to avoid such incidents.

Environment

Release: WKLOEB01300-11.3-Workload Automation-Agent for Oracle EBusiness Ste
Component: