Task Finish Date does not consider the user timezone when Date/Time Format Scale is "Day"

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Article ID: 36946

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise

Issue/Introduction

Issue: 

Task Finish Date do not consider the user timezone when Date/Time Format Scale is "Day"

Steps to reproduce: 

  1. Login to CA PPM as Admin. 
  2. Go to the Object --> Tasks --> Views 
  3. Go to the [Fields] for the "Task Properties" view and Set the "Date/Time Format Scale" for both Start and Finish attribute as "Day Time". 
  4. Do the same for "Task List" view. 
  5. Login as User X whose Time Zone is set as GMT. 
  6. Create a new project or open an existing one. 
  7. Go to the Task tab and create a new Task. 
  8. Select the Start and Finish Date and select a time for the Finish date 
  9. Now logout from that user who was in GMT Time Zone. 
  10. Login with User A, whose Time Zone is (GMT+13:00). 

Expected result: The finish date for that Task should be same for both User A and User B as both are in same timezone

Actual result: The finish date for the Task is not same for User A and User B. For User B, as the finish date is not having day and time format, so the timezone change is not getting considered

Environment: 

CA PPM 13.3, 14.1, 14.2, 14.3

Cause: 

Caused by CLRT-79593.

Resolution: 

This issue is currently getting in review with our sustaining engineering team and targeted to be fixed in one of the upcoming releases. 

Workaround: 

Change the display format of Finish date to Day Time format.

 

Environment

Release: ESPCLA99000-13.3-Clarity-Extended Support Plus
Component: