Aria Suite Lifecycle upgrade fails with error No Upgrade Available when using the Repository URL type
search cancel

Aria Suite Lifecycle upgrade fails with error No Upgrade Available when using the Repository URL type

book

Article ID: 369455

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • When upgrading Aria Suite Lifecycle from 8.12 and above you see error "No Upgrade Available" when using the "Repository Type: URL".

Environment

  • Aria Suite Lifecycle 8.12 and above.

Cause

  • This is due to the Repository Type URL (internal web server) hosting the upgrade files has a certificate that is not trusted by the ASL appliance.
  • This can also be related to the URL.
    • CAP downloads the manifest file from the provided custom_urls settings, which should be pointing to the base directory where the manifest directory containing manifest XML is present.

Resolution

For certificate issue:

 

Prerequisites:

  • You have a valid backup or temporary snapshot of the Aria Suite Lifecycle appliance.

Procedure:

  1. Download and copy the certificate to the appliance's trust store located at:
    /etc/ssl/certs
  2. Run the following command:
    /usr/bin/rehash_ca_certificates.sh
  3. Run the following command to clear the failed upgrade:
    rm /etc/vmware/cap/cap_am/update_status.json
  4. Log back into Aria Suite Lifecycle and retry upgrade.

 

 

For issues with the Repository URL:

  • Verify the path of the URL points to where the Manifest directory is located.