vCenter Service fail to start after changing the FQDN (fully-qualified domain name) of the vCenter Server Appliance
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vCenter Service fail to start after changing the FQDN (fully-qualified domain name) of the vCenter Server Appliance

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Article ID: 369413

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

After changing the Fully-qualified Domain Name of the vCenter Server, some or all of its services fail to start.

Environment

vCenter Server 6.7 U3

vCenter Server 7.0.x

vCenter Server 8.0.x

Cause

This issue can when the DNS entries for the new vCenter FQDN have not been properly created to allow for both forward and reverse name resolution.

 

 

Resolution

When making a change to the FQDN of the vCenter Server Appliance, you need to ensure that both required entries are properly created on the DNS server(s) used by the VCSA:

  • A record for forward name resolution, to be able to find the IP corresponding to the new FQDN
  • Pointer Record (PTR) for reverse lookup, for finding the new FQDN when looking with the IP address

In addition please verify the following requirements before attempting the FQDN change:

  1. Ensure that a fresh backup of the vCenter has been created. If the vCenter Server is part of an Enhanced Linked Mode replication group, please ensure that backups are created for all linked vCenter Servers as well. In case of a restore being required, all of the ELM nodes need to be restored.
  2. Changing the vCenter FQDN is only supported in vCenter Server 6.7 Update 3 or newer versions
  3. Specifically for vCenter Server 6.7 U3 (or any newer version before 7.0) ensure that the vCenter is running with an embedded Platform Service Controller (PSC). FQDN changes for setups with external PSCs are not supported.
  4. vCenter High-Availability (VCHA) needs to be disabled and removed before changing the FQDN. 
  5. External products which are registered with the vCenter will need by unregistered first, and should be reregistered after a successful change of the FQDN
  6. If the vCenter Server is joined to an Active Directory Domain, remove it from the domain prior to changing the FQDN and rejoin it afterwards

Furthermore, please be aware that additional steps might need to be required after the FQDN change was done: 

  1. While the FQDN change will not have any negative impact on Enhanced Linked Mode, it will break any Hybrid Linked Mode replication with Cloud vCenters. These will need to be recreated.
  2. If you are using custom certificates in vCenter Server, these will be need to be regenerated after the change.

 

Once you are aware of these implications and have taken the necessary steps, you can follow the steps below to change the FQDN of the vCenter Server:

  1. Open the VAMI User Interface of the VCSA (https://<current_vCenter_FQDN_or_IP>:5480) and login with the default administrator account
  2. Change into the "Networking" tab, click the "EDIT" button:
  3. Ensure that NIC 0 is selected in the wizard, then click [NEXT]:
  4. Expand "Hostname and DNS" to edit the FQDN (as well as the DNS servers, if necessary), then again click on [NEXT]:
  5. On the next page, enter the credentials of the default SSO administrator account ([email protected], or different, depending on how the SSO domain is named) and click [NEXT] once more:
  6. On the last page of the wizard, verify the new FQDN, and confirm that you have made a backup before attempting the FQDN change:
  7. Before clicking on [FINISH], scroll down and take note of the required additional steps:
  8. Once you click [FINISH], a new popup will appear with the title "Network update in progress". Wait until the process has finished, then log back into the VAMI interface and verify that the change has been done.
  9. Once the FQDN change was successful, please take the additional steps as shown in step 7.