Salt Minion is Failed to Deploy to Windows VM when User Permission is not Configured Properly
search cancel

Salt Minion is Failed to Deploy to Windows VM when User Permission is not Configured Properly

book

Article ID: 369395

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Salt Minion is failed to deploy onto Windows VM
  • Follow the chapter "Enable Salt-Master Debug Logging" in the article below to set "log_level_logfile" in "/etc/salt/master" to "debug", error "ERROR_ACCESS_DENIED" can be found in log "/var/log/salt/master" when trying to access SMB server on remote Window VM on TCP port 445
    How to Enable debug logging on SaltStack
pypsexec.exceptions.SCMRException: Exception calling ROpenSCManagerW. Code: 5, Msg: ERROR_ACCESS_DENIED
[DEBUG   ] Retrying psexec connection to host <Windows VM IP> on port 445 (try 1)

Environment

This issue can happen in Aria Automation Config 8.x

Cause

When Salt Minion is to be deployed, Windows local username or Domain username is to be filled as the picture below:

  • To install Salt Minion on a deployed VM, username is supposed to be filled in "Attach SaltStack Resource" window.




  • To install Salt Minion during VM deployment, username is filled in the template. Refer to this link:
    Add the SaltStack resource to the cloud template

If this username has wrong permission to the folder shared by SMB, Salt Minion will be failed to deploy with error "ERROR_ACCESS_DENIED" in /var/log/salt/master

Resolution

Please make sure the "username" has full access on the SMB share folder.