Salt Minion Presence shows "Disconnected"
search cancel

Salt Minion Presence shows "Disconnected"

book

Article ID: 369381

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Salt Minion Presence shows "Disconnected" on Aria Automation Config Web Page:

Environment

This issue can happen in Aria Automation Config 8.x

Cause

The "Disconnected" state can be caused by:

  • Wrong status in Salt Database
  • Network issue between Salt-Master and Salt-Minion.

Resolution

1. Execute "test ping" to see if the presence status can change from "Disconnected" to "Present" after that

2. If the presence status is still "Disconnected" after step 1st, please test TCP connection from Salt-Minion to Salt-Master's port 4505/4506.

  • For Windows VM, powershell command Test-NetConnection can be used like: Test-NetConnection <Salt-Master IP> -port 4505 or 4506:



  • For Linux VM, telnet can be used like: telnet <Salt-Master IP> 4505 or 4506

3. If network connectivity test returns successful, please restart salt-minion on GuestOS to see if presence status on Aria Automation Config can change to "Present"

4. If all above procedures cannot work, please contact Broadcom/VMware support for further troubleshooting.