Error: "ConfigException occurred 'ConfigDll could not find the config toolbox', return code 0 ... 'The system cannot find the file specified (0x00000002), location" when 'Apply System Configuration' task
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Error: "ConfigException occurred 'ConfigDll could not find the config toolbox', return code 0 ... 'The system cannot find the file specified (0x00000002), location" when 'Apply System Configuration' task

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Article ID: 369256

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

After upgrading to ITMS 8.7.2 from ITMS 8.7 GA, when running the 'Apply System Configuration' task the SMP Console returned an error even though the endpoint was successful in renaming and joining the system to a domain.

The error message seen in the SMP Console was:

ErrorMessage: ConfigException occurred 'ConfigDll could not find the config toolbox', return code 0, system error 'The system cannot find the file specified (0x00000002), location 'ConfigDll.cpp:154'

Environment

ITMS 8.7.2

Cause

Image contains the old agent and Deployment Solutions plugin which could not report back to the Notification Server

Resolution

In the deploy of image task, enable the 'Upgrade Symantec Management Agent to latest version' and add 'Deployment Solution Plug-in' under 'Select SMP agent plugins to be configured during upgrade' feature to the task as shown in the following screenshot: