Internal Server Error -Unable to get managed connection for OptinuityDS
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Internal Server Error -Unable to get managed connection for OptinuityDS

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Article ID: 369199

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

CA Process Automation services are stopped, we not able to obtain login console.


2024-06-02 21:40:11,950 ERROR [org.hibernate.util.JDBCExceptionReporter] [3.68.101-8443-7] Unable to get managed connection for OptinuityDS; - nested throwable: (javax.resource.ResourceException: Unable to get managed connection for OptinuityDS)

Environment

Release: 4.+

Components: Process Automation Base

Cause

Customer has recently performed in-place upgrade of their ITPAM applications and also provisioned new Microsoft SQL2022 and migrated their DB to the new server
When the old DB server was powered down for pending decommission, they are unable to establish console connection to any of the ITPAM applications

Resolution

connection strings changed from the old to the new target DB server name in OasisConfig.properties file