Unable to attach files from secondary servers.

book

Article ID: 36915

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Symptoms:

When attempting to upload files via a secondary server, the error message "Failed to upload the file 'File name'" appears immediately after clicking on the <Start Upload> button. The files can be uploaded successfully via the primary server. If we add a Repository Daemon to the secondary servers and change the Repository server to the secondary server, the upload works fine.

When we collect a Console log of the browser, such as Chrome Console log, the following error message is written.

“XMLHttpRequest cannot load http://sdm_sv:8080/CAisd/UploadServlet. Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://sdm_sv:8080' is therefore not allowed access.” 

 

Environment:

Windows

 

Cause:

The problem is caused by Access Control.  

If you install the Service Desk Manager Cumulative #2 patch, but do not follow the mandatory steps of r14.1.02 Post Installation Steps for CA SDM Conventional Configuration so as not to use Access Control, you will encounter the problem.

 

Resolution:

Please follow the Mandatory Steps of the Service Desk Manager Cumulative #2 Post Installation steps.

NOTE: If Repository Daemon is running on a primary server only, you need to make the changes on the primary server.

 

Additional Information:

r14.1 Wiki site - Implementing - Implementing CA Service Desk Management 14.1.02 - Post-Installation Tasks - Post Installation steps for CA SDM Conventional Configuration - Mandatory Steps

TEC1968744: web.xml changes are lost after reboot\recycle of the SDM servers

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: