Process error: You do not have the rights to perform the action
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Process error: You do not have the rights to perform the action

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Article ID: 369079

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Retrying errored process steps due to lack of permissions does not complete even if the user is granted relevant permissions

STEPS TP REPRODUCE

1. Classic PPM > Administration > Data Administration > Processes
2. Create a process based on the project object: MyProjectProcess
   Start option: On-demand
3. Start step > Set a System Action that updates a project field
   example: Set Status = Approved
4. Validate the process
5. Administration > Resources > Create a resource > TestUser
6. Grant following rights:
   Process - Start - All
   Process - Manage - All
   Projects - Navigate
   Project - View Management - All
7. Login as the newly created user
8. Home > Projects > Edit any project
9. Go to the process tab > Available processes
10. Start the process MyProjectProcess
11. The process errors with the following error:
    You do not have the rights to perform the action.
12. As admin, go to the TestUser user profile and grant the following right:
    Project - Edit Management - All
13. As TestUser > Go back to the project processes tab > Initiated
14. Open the messages icon where the error is seen and click Retry

Expected Results: The step to go through successfully as the user has got edit rights now
Actual Results: You do not have the rights to perform the action.

Environment

Clarity 16.2.1, 16.2.2

Cause

This is caused by DE80878

Resolution

Due to the complexity of the fix and the impacted code area extensive validation is required. Taking that into account a user story has been raised and therefore the defect has been closed at this time waiting for future work.

Workaround: Flush the Clarity cache and retry the errored step again