Missing interface/s in DX NetOps Performance Management
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Missing interface/s in DX NetOps Performance Management

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Article ID: 369059

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Neither CAPM are discovering some interfaces of devices even though the devices have these lan interfaces enabled. For example, while lan1 & lan2 are shown, lan3 is not, even though it is active on the device:

Environment

DX NetOps CA Performance Management (CAPM) all releases

Cause

Required data is missing from the MIB data of the device. A working device will show the names in the MIB. For example:

# grep -i lan device_mib.walk
1.3.6.1.2.1.31.1.1.1.1.2      , OctetString , lan1

1.3.6.1.2.1.31.1.1.1.1.3      , OctetString , lan2

1.3.6.1.2.1.31.1.1.1.1.4      , OctetString , lan3

The OID - 1.3.6.1.2.1.31.1.1.1.1 is the textual name of the interface (the last digit, the 2 or 3, represents the ifIndex of the interface). 

If there is no Interface MIB table entry for the textual name lan3:

# grep -i lan device_mib.walk
1.3.6.1.2.1.31.1.1.1.1
.2      , OctetString , lan1

1.3.6.1.2.1.31.1.1.1.1.3      , OctetString , lan2

Then without this, it will not be discovered or shown in PM or Spectrum.

Resolution

You need to get the device to make the required interface visible in its MIB data. The will be configured within the SNMP agent of the device