RA agent sheets are not available via AWI load balancer connection
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RA agent sheets are not available via AWI load balancer connection

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Article ID: 369033

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When viewing a job (for instance RA REST JOBS) the Web Service sheets are not available:

This was only an issue after an upgrade of the agent, and when trying to access the RA job using the AWI Load Balancer address.

If the URL used was the direct URL for AWI node 1, the sheets were displayed as expected:

If the URL was either the load balancer address or the node 2 direct URL, the sheets were not visible.

Environment

Automic Automation version 21 and 24
RA WebService REST agent

Cause

After the agent was upgraded, the AWI cache was deleted only on one of the AWI servers.

Resolution

Once the AWI cache was deleted on both AWI servers, the sheets were visible from all URLs - Load Balancer, and the direct node URLs for both servers.

The cache for AWI when running with Jetty is located here:

WebInterface\osgi-tmp\0\org.eclipse.osgi -- Stop AWI and delete the org.eclipse.osgi folder

If AWI is running with Tomcat, the cache is the /work folder

ie: Tomcat 9.0\work -- Stop Tomcat and delete the work folder. 

These folders are recreated when either Jetty or Tomcat are restarted.