PDF Export Files - "Failed to launch" Chrome
search cancel

PDF Export Files - "Failed to launch" Chrome

book

Article ID: 369020

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When attempting to export from the MUX an error is displayed in the UI:

"EXP-01000: Error generating PDF export"

When reviewing the Clarity app logs, an error similar to this displays:

Caused by: com.microsoft.playwright.impl.DriverException: Error {
  message='Failed to launch: Error: spawn /fs0/clarity/playwright/chromium-1091/chrome-linux/chrome EACCES
  name='Error
  stack='Error: Failed to launch: Error: spawn /fs0/clarity/playwright/chromium-1091/chrome-linux/chrome EACCES
    at ChildProcess.<anonymous> (/fs0/clarity/tomcat-app-deploy/temp/playwright-java-14455483442130938458/package/lib/utils/processLauncher.js:127:14)
    at Object.onceWrapper (node:events:629:26)
    at ChildProcess.emit (node:events:526:35)
    at ChildProcess._handle.onexit (node:internal/child_process:292:12)
    at onErrorNT (node:internal/child_process:484:16)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
}

Environment

Clarity - Linux

Cause

1. On the Clarity app server Chrome in the path: /fs0/clarity/playwright/chromium-1091/chrome-linux/chrome is missing executable rights.

2. We also observe the error when using PPM version 16.2.1 on Linux Version 7. The PAS for 16.2.1 suggests/certifies the use of Linux 8 and above.

Resolution

Executable rights needs to be assigned to the Chrome application. Clarity uses Chrome on the app server to perform the export function.