Problem:
After unexpected reboot of the SOI server all connectors on WebUI showing offline.
Environment:
SOI 3.x, 4.x
Cause:
Please review SOI\log\ifw.log you might see following errors
2016-01-22 00:51:15,931 ERROR [IFWProxy-0] jms.JMSPublisher - [email protected]<Managaer_Name>: AMQ Connection failed.Connection refused: connect.
com.ca.sam.ifw.api.exceptions.MsgBusConnectionFailureException: Connection refused: connect
2016-01-21 20:28:14,144 ERROR [ActiveMQ Task-1] failover.FailoverTransport -112-org.apache.activemq.activemq-core-5.7.0 - Failed to connect to [tcp://<Manager_IP>:61616?daemon=true] after: 31 attempt(s)
Which means AMQ is corrupted and it is not allowing IFW connections.
Resolution
To fix this perform following steps.
1. Stop all services on connectors, UI Servers and SOI Manager.
2. Clean data under ..\CA\SOI\tomcat\webapps\activemq-web\activemq-data
3. Start services in following sequence
A) Start CA SAM Application Server
B) Start CA UCF Broker
Wait till all the services started (Check triage test in Manager debug page)
C) Start UI Interface Server
D) Start CA SAM Store Indexer
Wait till all the services started (Check triage test in UI debug page)
E) Start CA SAM Integration Services
F) Start CA SAM Event Management
G) Start all remaining connectors.