Error while trying to access CA Jasper Report from IM (Error UID: ab284ad7-718e-44d1-a629-2824ec0cf044)
search cancel

Error while trying to access CA Jasper Report from IM (Error UID: ab284ad7-718e-44d1-a629-2824ec0cf044)

book

Article ID: 368915

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

Getting an Error when trying to access the Jasper Report Server.

Error Message
There was an error on the server. Try again or contact site administrators. (Error UID: ab284ad7-718e-44d1-a629-2824ec0cf044)

 

Application Server logs shows:

ERROR [com.ca.ims.jasperreporting.JasperUtils] (default task-75) Error while getting server info org.apache.http.conn.HttpHostConnectException: Connect to x.x.x.x:8080 [/x.x.x.x] failed: Connection refused (Connection refused)

INFO  [com.ca.ims.jasperreporting.JasperUtils] (default task-75) trying to generate jasper token for user(xyz).

 

Environment

IM 14.5 

Jaspersoft 8.2

Cause

Connection getting refused in the Customer's Environment

Resolution

1)First Test the Connection from the IM User Console

=> Tasks>System>Reporting>Report Server Connection

2) Fill in the details and click on the Test Connection Button

3) If the Test Connection is successfully, check the Tomcat Services status on Jasper Report Server

Restarting the Tomcat Services will resolve the issue