Unable to define an 'Image' in vCenter Cluster, when attempting to update ESXi hosts after vCenter Server upgrade from 6.7x up through to 8.0.x
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Unable to define an 'Image' in vCenter Cluster, when attempting to update ESXi hosts after vCenter Server upgrade from 6.7x up through to 8.0.x

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Article ID: 368872

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Updated On:

Products

VMware vCenter Server VMware vCenter Server 7.0 VMware vCenter Server 8.0 VMware vSphere ESXi VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

After upgrading vCenter Server from 6.7.x to 8.0.x and then attempting to upgrade ESXi hosts, the following situations can occur:

  • When trying to convert from Host 'Baseline' to Host 'Image' in order to upgrade ESXi 7.x hosts to ESXi 8.x, no versions for 8.x are available in the Select Version dropdown, even when attempting to manually defining an image:

  • When Attempting to perform a Sync Updates task with vSphere Lifecycle Manager generates an error in the vSphere Client as well as in /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log:

"A general system error occurred: Download patch definitions task failed while syncing depots. Error: 'integrity.fault.MetadataDownloadFailure: Cannot download patch definitions.' "

Cause

This issue occurs when upgrading from earlier releases, the Update Manager depots are preserved, including all of the items downloaded or used with those prior releases.  After upgrading to vSphere 7.0 and later, some of the downloaded items are no long useable with vSphere Lifecycle Manager, causing vSphere Lifecycle Manager to be unable to complete its synchronization process successfully.  Additionally, there may be an issue with one of the configured Depots.

Resolution

Workaround:

This issue can be temporarily bypassed by disabling the particular problematic Download Source (Depot) and running a Sync Updates task again.  To determine the Depot to disable, review the /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log and look for similar entry:

[YYYY-MM-DDTHH:MM:SS] error vmware-vum-server[12614] [Originator@6876 sub=VciSigUpdateTask.SigUpdateTask{7}] [vciSigUpdateTask 559] \n\nError downloading ESXi updates from https://hostupdate.vmware.com/software/VUM/PRODUCTION/addon-main/vmw-depot-index.xml: no element found

This would indicate that there may be an issue with default "addon-main" depot.  To disable this depot, perform the following:

  1. In the Lifecycle Manager Administrative interface, click Patch Setup -> Settings
  2. Locate the problematic Depot by reviewing the URL contents and matching that to the log entries above.
  3. Click the radio button next to that particular depot then click the DISABLE link above.
  4. Perform another Sync Updates task from the Actions menu. 

Note: depending on the vendor and/or contents of the Depot, disabling a depot may affect the ability to receive all available host patches from VMware or other vendor patches.  For example, if the depot to be disabled is the "/VUM/PRODUCTION/main/vmw-depot-index.xml", it would be advisable to reset the VUM DB using the steps below.

Resolution:

This issue can be resolved by resetting the Update Manager Database: