After upgrading VMware Identity Manager, the upgraded node does not appear to respond from the network.
Your load balancer can no longer reach the VMware Identity Manager Service VA.
Services on the VMware Identity Manager appliance may not start or if they do start, will not stay running for long.
If you preform nslookup on your VMware Identity Manager service VA, it will not be able to reach DNS.
If you check the /etc/resolv.conf file, you will see that there is no nameserver address or it has an address similar to 127.0.0.53.
Adding a nameserver value in /etc/resolv.conf file will be lost upon reboot of the VMware Identity Manager service VA.
sometime its shows an red error box when trying to load the vidm UI.
NOTE: The /etc/resolv.conf is symlinked to /run/systemd/resolve/stub-resolv.conf
Environment
VMware Identity Manager 3.3.x
Cause
A nameserver value in /etc/resolv.conf file will be lost upon reboot of the VMware Identity Manager service
Resolution
As a workaround, you can set your DNS values in the /etc/systemd/resolved.conf file.
This file is persistent, and the settings will last through reboots.
1. Check /etc/resolv.conf file, if DNS record missing. Added the DNS IP and restarted the horizon service.
2. The line that needs to be edited is the FallbackDNS value from /etc/systemd/resolved.conf . This is normally commented out. You will need to remove the hash (#) in front of the value for it to work.
4. Also, IPv6 is not supported by VMware Identity Manager. When editing the resolved.conf do not add any IPv6 addresses in the FallbackDNS line. There are some examples in the file at the start and they should be removed.