Stale Edge Node Entry found alarm in NSX
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Stale Edge Node Entry found alarm in NSX

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Article ID: 368790

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Stale NSX Edge Node Entry Found alarm is generated in NSX.
  • The alarm display: "Edge VM Present In NSX Inventory Not Present In vCenter".
  • Issue is noticed after NSX Edge node is replaced.
  • Deleted edge node is not visible in NSX UI.
  • GET /api/v1/transport-nodes/<tn-id>/state API returns transport node could not be found.
  • POST https://<nsx-manager>/api/v1/transport-nodes?action=clean_stale_entries API runs successfully.

Environment

NSX 4.1

Cause

The issue occurs when an edge node delete is in progress however, another process is initiated by L2 (layer between Edge and Edge Host that contains common config) causing edge node not to be found.
An alarm is raised however, edge node is deleted by the earlier process.

Resolution

This issue has been resolved in NSX 4.2.0.

Workaround:

To resolve the issue, try to clear the alarm using the API POST https://<nsx-manager>/api/v1/alarms/<alarm-id>?action=set_status&new_status=RESOLVED

Note: Update the <alarm-id> in the API before running it.

If any new alarm is generated again, restart the phonehome-coordinator service on all the manager nodes

/etc/init.d/phonehome-coordinator status    #Check the status of phonehome-coordinator
/etc/init.d/phonehome-coordinator restart   #Restart the phonehome-coordinator service

If the issue is not resolved, restart the proton service on all the NSX manager nodes. 

Note: Make sure the proton service is up and the cluster is stable before restarting the service on the second and third nodes. 

/etc/init.d/proton status    #Check the status of proton service
/etc/init.d/proton restart   #Restart the proton service

If issue persists, collect all the 3 NSX Manager node log bundles and open a support request with Broadcom.