Issue:
We run a daily job to create an iDash latency report on the iDash Client.
The report used to work fine for months, but suddenly started to fail with errors :
Exception in thread "PoolCleaner[29855319:1451473016745]" java.lang.OutOfMemoryError: Java heap space
com.ca.idash.core.exception.IdashException: java.lang.OutOfMemoryError:Java heap space
java.lang.OutOfMemoryError:Java heap space
com.ca.idash.core.exception.IdashException: java.lang.OutOfMemoryError:Java heap space
However, when the same command is run directly on the iDash servers the report is generated without any issues.
Environment:
WA iDash Release 11.4
Cause:
Problem due to lack of Java memory on the iDash Client
Resolution :
The solution is to increase the Java memory on the client by passing “-Xms2048m –Xmx2048m” in the command line.
Example :
/opt/idash/bin/idgencsv -Xms2048m -Xmx2048m -f /tmp/graham.csv –t latency.report –i HP1 –v
These options are added at command line when you execute the "idgencsv" command