The Import in IG from IM stucked in 80% and finally failed 100%
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The Import in IG from IM stucked in 80% and finally failed 100%

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Article ID: 368769

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Updated On:

Products

CA Identity Suite

Issue/Introduction

The Import in IG from IM stucked in 80% and finally failed 100%

The Events from Connector CAIM shows message:

Error to execute connector import: CAIM
Fail to import from CSV Files. [EXC]: com.eurekify.command.CommandExecutionException, [MSG]: org.springframework.jdbc.UncategorizedSQLException: PreparedStatment...
Error: org.springframework.jdbc.UncatagorizedSQLException: PreparedStatementCallback; uncategorized SQLException for SQL [INSERT INTO Users (UserID, DatabaseID, ....

 

Environment

CA Identity Suite Vaap 14.4.2 CHF1

Cause

After enabled IG DEBUG mode ( set_log_level_ig DEBUG) was possible to identify in the logs that the cause of issue is because of size of column UserName was truncated for two users only.

SQL state [S0001]; error code [2628]; String or binary data would be truncated in table 'EUREKIFY_SDB.dbo.Users', column 'UserName'. Truncated value: '<User Name with long name (with 850 caracters) and the field is truncated in 256 characters.

Resolution

Fix the users with more than 256 characters in the Name and try import again that will work.

Additional Information

After finish the troubleshoot please don't forget to disable the IG DEBUG mode issuing the command:

 set_log_level_ig INFO