Upgrading NSX fails to start due to "End User License Agreement not accepted."
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Upgrading NSX fails to start due to "End User License Agreement not accepted."

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Article ID: 368768

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Updated On:

Products

VMware NSX

Issue/Introduction

While attempting to upgrade NSX, of any version to any version, the upgrade fails to start at the Edge node upgrade stage with the error message popup: "End User License Agreement not accepted."

 

Environment

VMware NSX-T Data Center
VMware NSX

Cause

This is caused by the EULA acceptance value being set to false.

To determine the current value of the EULA acceptance run the following GET API call:

GET https://<nsx-manager-ip>/api/v1/upgrade/eula/acceptance

If the EULA has not been properly accepted, the returned output will be:

{
"acceptance": false
}

 

Resolution

The EULA acceptance level can be set to true with the following API call:

POST https://<nsx-manager-ip>/api/v1/upgrade/eula/accept

If successful, this will return a 200 response code and a rerun of the GET API call will return:

{

"acceptance": true

}

 

Alternatively, you can run the below command from NSX-T manager root login to update the EULA acceptance level to true 

curl -X  POST  -k -u   admin:'Password'  "https://<nsx-manager-ip>/api/v1/upgrade/eula/accept"

Additional Information

NSX API guide can be found at the following location: https://developer.broadcom.com/xapis/nsx-t-data-center-rest-api/latest/