Set Sender or From email address for Spectrum OneClick emails
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Set Sender or From email address for Spectrum OneClick emails

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Article ID: 368735

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

No emails are received for Spectrum Alarms.

In the Spectrum OneClick UI when we right click on an Alarm and choose the Mail option the email is never received.

In the $SPECROOT/tomcat/logs/catalina.out (Linux) or stdout.log (Windows) an error is seen:

javax.mail.SendFailedException: Send failure (javax.mail.MessagingException: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM

The email requirements for the environment state:

SMTP Requirements:

  • The “Sender (or from)” address must be a valid <companyName>.com email address in case of any undeliverable emails (it can be routed back correctly). If you do not require the email to be routed back, you may use the generic email address as the sender address: EmailNotification@<companyName>.com

In the OneClick Administration web site, in the Email Configuration page, there is no location for setting a global Sender/From address.

Environment

All supported DX NetOps Spectrum releases

Cause

Two possible but related causes are involved.

  • The user logged into OneClick that requests the email has no email address set for their user.
  • The user logged into OneClick that requests the email has an email address set for their user. The email isn't a valid address known to the environments email server(s).

Resolution

Ensure the user logged into the OneClick UI has a valid email address set.

  1. Log in to the OneClick UI as the target user.
  2. Go to the Users tab.
  3. Select the User to display the Component Detail pane for the user. Set the E-Mail address field value. This will be used for the Sender/From address for emails sent via OC directly.

Additional Information

Note this does not affect addresses used by the Alarm Notifier application.

This does not prevent setting of an invalid email address. Ensure the email set is valid in your environment.

Best practice to avoid this issue is setting valid email addresses on new user accounts when created.