Uploading the PAK file in Aria Operations failed with an error "Upload Failed."
book
Article ID: 368613
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
Uploading a PAK file to VMware Aria Operations 8.10.x and above fails
When Attempting to install .pak file (upgrade or MP) from admin UI, you receive an error that prevents the installer to start with error 'Upload Failed '
Environment
Aria Operations 8.10.x
Aria Operations 8.12.x
Aria Operations 8.14.x
Aria Operations 8.16.x
Aria Operations 8.17.x
Cause
This can occur due to misconfiguration found in the file "/usr/lib/vmware-vcopssuite/utilities/conf/vcops-photon-apache.conf"
Resolution
Connect to the primary node via SSH.
On the primary node, verify if the line "LimitRequestBody 0" exists in the file "/usr/lib/vmware-vcopssuite/utilities/conf/vcops-photon-apache.conf"
Repeat the verification on all nodes in the cluster including Cloud Proxies.
Ensure the file has "LimitRequestBody 0" present in the conf file on all nodes.
If the line "LimitRequestBody 0" is missing on any node:
Create a backup of the "vcops-photon-apache.conf" file
Add the line "LimitRequestBody 0" to the configuration file "vcops-photon-apache.conf"
Save the changes made to the file
Ensure the permission of this file is retained
If the configuration changes were made on any node, restart the httpd service on that specific node using the command: service httpd restart
Upload the PAK file again and verify if the upload is successful
Note: Below is the comparison of the conf file between the working and non-working node: