SDM does not load on IIS with NTLM after an upgrade
search cancel

SDM does not load on IIS with NTLM after an upgrade

book

Article ID: 368586

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After upgrading to 17.4 RU2 from RU1, SDM IIS SSL URL does not load.

This occurs when having in NX_ROOT\NX.env:


@NX_STRIP_DOMAIN_NAME=No
@NX_LDAP_ENABLE_AUTO=Yes

If NX_STRIP_DOMAIN_NAME is set to Yes, the issue does not occur
If NX_LDAP_ENABLE_AUTO=Yes is not installed, the issue does not occur.

Stdlogs show the following errors:

Lost connection to virtdb bopLDAP:

 <SERVER> domsrvr:wsp            16212 ERROR        sql_prod.c             567 Lost connection to virtdb bopLDAP

Loss of connection to process has been detected:

 <SERVER> domsrvr:wsp            16212 SIGNIFICANT  connmgr.c             2560 Loss of connection to process (8496|bopLDAP) has been detected

LDAP agent prov#XXX_bopLDAP going down:

 <SERVER> ldap_agent_nxd         16116 SIGNIFICANT  ldap_agent.c           629 LDAP agent prov#16116_bopLDAP going down

Daemon ldap_virtdb died: restarting:

 <SERVER>pdm_d_mgr               5656 ERROR        daemon_obj.c          2000 Daemon ldap_virtdb died: restarting

Event viewer shows:

Faulting application name: ldap_virtdb.exe, version: 17.4.2.168

Environment

SDM 17.4 RU2

SDM integrated with LDAP 

Cause

Defect with 17.4 RU2

Resolution

The solution to this defect is included in 17.4 RU3