Logs and outputs needed for troubleshooting SD-Access (SDWAN-Client) issues
search cancel

Logs and outputs needed for troubleshooting SD-Access (SDWAN-Client) issues

book

Article ID: 368552

calendar_today

Updated On:

Products

VMware VeloCloud SD-Access

Issue/Introduction

The SD-Access Client runs on user system or servers. The logs saved by the system is always based on the user local system time.

To troubleshoot the connectivity issue between two users or server , please collect the logs and the local system time.

This is very informative when the users have different system time zones configured.

 

Environment

VMware SDWAN-Client , Velocloud SD-Access

Cause

The above command output taken during the issue state will help narrowing down the issue.

Open a support case along with clear issue statement and requested command outputs and logs files mentioned in this article.

Resolution

Logs are available in the directory (based on OS)

  • Windows: C:\Program Files (x86)\SD-WAN Client\Service\logs
  • Linux: /opt/sdwan-client/core/logs
  • Mac: /Applications/SD-WAN\ client.app/Contents/Resources/logs

Client-logs are available in the directory(based on OS)  --- This is needed for any client UI issue (eg: Authentication error, UI unresponsive etc)

  • Windows: C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs
  • Mac: /Users/<user_name>/Library/Application Support/sdwan-client/client-logs

It is always advised to collect all the files including directories inside the logs directory of the user system

example: Files and directories can be seen inside the log directory.

Output To be collected for a connectivity issue

For any SDWAN Client connectivity issue, please collect below outputs from both end users.

If issue is between User and Client-Connector , then logs from user and Client-Connector need to be collected.

The commands will work from the Windows Powershell.

C:\Program Files (x86)\SD-WAN Client> get-date
C:\Program Files (x86)\SD-WAN Client> get-timezone
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --ip
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe -c
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe -s
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --status=extended
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --routes
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --nat
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --trusted
C:\Program Files (x86)\SD-WAN Client> ipconfig /all


For DNS resolution issues, please collect additional outputs from the enduser along with the previous command output.

The commands will work from the Windows Powershell.

C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=bypass_list
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=settings
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=compatibility
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=connected_cc
C:\Program Files (x86)\SD-WAN Client> nslookup <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> route print
C:\Program Files (x86)\SD-WAN Client> ping <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> ping <client connector IP>
C:\Program Files (x86)\SD-WAN Client> tracert.exe <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> get-netadapter
C:\Program Files (x86)\SD-WAN Client> Get-DnsClientServerAddress
C:\Program Files (x86)\SD-WAN Client> resolve-dnsname <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> nslookup <host.domain.x> <e814-0 adapter ip>

 

The commands will work from the MAC iTerminal.

User@XXXXXX logs %date
User@XXXXXX logs %ifconfig
User@XXXXXX logs % sdwan-client-cli -c
User@XXXXXX logs % sdwan-client-cli -ip
User@XXXXXX logs % sdwan-client-cli -s
User@XXXXXX logs % sdwan-client-cli --nat
User@XXXXXX logs % sdwan-client-cli -routes
User@XXXXXX logs % sdwan-client-cli --trusted
User@XXXXXX logs % sdwan-client-cli --status=extended

For DNS resolution issues

User@XXXXXX logs % sdwan-client-cli --dns
User@XXXXXX logs % sdwan-client-cli --dns=bypass_list
User@XXXXXX logs % sdwan-client-cli --dns=settings
User@XXXXXX logs % sdwan-client-cli --dns=compatibility
User@XXXXXX logs % sdwan-client-cli --dns=connected_cc


From SDWAN-Client version 1.39.9 a new Command is introduced to collect the diagnosis data from the SDWAN-Client user. It collects the command outputs and the ananda.log* files and saves as a file named as sdwan-client-diag-bundle_<sw version>_yyyy-mm-dd-hh-mm-ss.zip

Example:

PS C:\Program Files (x86)\SD-WAN Client\Service\logs> sdwan-client-cli.exe --diag_dump
Executing Cli commands ...
C:\Program Files (x86)\SD-WAN Client\Service\config.json
C:\Program Files (x86)\SD-WAN Client\Service\dns_suffixes_secured.json
C:\Program Files (x86)\SD-WAN Client\Service\lru_connections.json
C:\Program Files (x86)\SD-WAN Client\Service\noNetworkEvents.json
C:\Program Files (x86)\SD-WAN Client\Service\securedCore.json
C:\Program Files (x86)\SD-WAN Client\Service\securedDns.json
C:\Program Files (x86)\SD-WAN Client\Service\securedProxy.json
C:\Program Files (x86)\SD-WAN Client\Service\server.json
C:\Program Files (x86)\SD-WAN Client\Service\serviceKey.json
        9 file(s) copied.
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.1.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.10.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.2.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.3.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.4.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.5.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.6.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.7.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.8.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\ananda_connection_history_db.json
C:\Program Files (x86)\SD-WAN Client\Service\logs\post-install.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\sdwan-client-diag-bundle_1.39.9_2025-01-09-12-34-33.zip
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-03-14 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-05-23 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-05-29 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-07-12 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-09-19 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2024-09-27 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\Setup Log 2025-01-09 #001.txt
C:\Program Files (x86)\SD-WAN Client\Service\logs\watchdog.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\win7-update.log
       22 file(s) copied.
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\.ac20c15915738b168c716f8ccf4c40c9d5484795-audit.json
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\ananda-2025-01-05.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\ananda-2025-01-06.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\ananda-2025-01-07.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\ananda-2025-01-08.log
C:\Program Files (x86)\SD-WAN Client\Service\logs\client-logs\ananda-2025-01-09.log
        6 file(s) copied.
Executing ipconfig /all ...
Executing powershell -Command Get-DnsClientServerAddress ...
Executing route print ...

7-Zip (a) 19.00 (x86) : Copyright (c) 1999-2018 Igor Pavlov : 2019-02-21

Scanning the drive:
1 folder, 54 files, 18057066 bytes (18 MiB)

Creating archive: .\sdwan-client-diag-bundle_1.39.9_2025-01-09-12-39-02.zip

Add new data to archive: 1 folder, 54 files, 18057066 bytes (18 MiB)


Files read from disk: 54
Archive size: 2704149 bytes (2641 KiB)
Everything is Ok
Generated sdwan-client diagnostic bundle '.\sdwan-client-diag-bundle_1.39.9_2025-01-09-12-39-02.zip'
PS C:\Program Files (x86)\SD-WAN Client\Service\logs>

Additional Information

There is a batch file "SDA-User-Diagnosis_report_v3.1.bat" is attached to the KB. Windows User can download the batch file and execute (double mouse click) that during the problem state .

The batch file will collect the logs and command output and save the information inside Documents/SD-WAN_Client directory.

The command output will be saved in a file named in the format YYYYMMDD_HHMMSS_SDA-user_diag-report.txt

The logs will be saved in a compressed file (.zip) names as YYYYMMDD_HHMMSS.logs.zip.

Please upload both the files while reporting the issue with support.

=========================================================================

If SDWAN-Client user is running 1.39.9 or higher you can collect the logs by using the CLI command  sdwan-client-cli.exe --diag_dump

In future releases this option will be integrated with User UI, so user can click on the UI for the diag_dump to be generated.

Attachments

SDA-User-Diagnosis_report_v3.1.bat get_app