Logs and outputs needed for troubleshooting SD-Access (SDWAN-Client) issues
search cancel

Logs and outputs needed for troubleshooting SD-Access (SDWAN-Client) issues

book

Article ID: 368552

calendar_today

Updated On:

Products

VMware VeloCloud SD-Access

Issue/Introduction

The SD-Access Client runs on user system or servers. The logs saved by the system is always based on the user local system time.

To troubleshoot the connectivity issue between two users or server , please collect the logs and the local system time.

This is very informative when the users have different system time zones configured.

 

Environment

VMware SDWAN-Client - 1.34.11

Cause

The above command output taken during the issue state will help narrowing down the issue.

Open a support case along with clear issue statement and requested command outputs and logs files mentioned in this article.

Resolution

Logs are available in the directory (based on OS)

  • Windows: C:\Program Files (x86)\SD-WAN Client\Service\logs
  • Linux: /opt/sdwan-client/core/logs
  • Mac: /Applications/sdwan-client.app/Contents/Resources/logs

 

Output To be collected for a connectivity issue

For any SDWAN Client connectivity issue, please collect below outputs from both end users.

If issue is between User and Client-Connector , then logs from user and Client-Connector need to be collected.

The commands will work from the Windows Powershell.

 

C:\Program Files (x86)\SD-WAN Client> get-date
C:\Program Files (x86)\SD-WAN Client> get-timezone
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --ip
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe -c
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe -s
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --status=extended
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --routes
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --nat


For DNS resolution issues, please collect additional outputs from the enduser along with the previous command output.

The commands will work from the Windows Powershell.

C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=bypass_list
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=settings
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=compatibility
C:\Program Files (x86)\SD-WAN Client> sdwan-client-cli.exe --dns=connected_gw
C:\Program Files (x86)\SD-WAN Client> nslookup <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> route print
C:\Program Files (x86)\SD-WAN Client> ping <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> ping <client connector IP>
C:\Program Files (x86)\SD-WAN Client> tracert.exe <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> get-netadapter
C:\Program Files (x86)\SD-WAN Client> Get-DnsClientServerAddress
C:\Program Files (x86)\SD-WAN Client> resolve-dnsname <host.domain.x>
C:\Program Files (x86)\SD-WAN Client> nslookup <host.domain.x> <e814-0 adapter ip>