A timeout is received browsing to the UI in Aria Operations for Logs 8.x
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A timeout is received browsing to the UI in Aria Operations for Logs 8.x

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Article ID: 368535

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

!! This should not be the first troubleshooting steps attempted when the VMware Aria Operations for Logs UI is not available due to a browser timeout. !!

This issue is very rare and is a direct result of making unsupported modifications to the appliances. Other much more common issues exist that are more likely the cause of a browser timeout.

  1. A timeout error is received in the browser when navigating to the Aria Operations for Logs UI using the VIP AND all node FQDNs or IPs

  2. On at least one node in the cluster:

    • The command   ls -l /usr/lib/systemd/system/loginsight_firewall_*  returns the error   ls: cannot access '/usr/lib/systemd/system/loginsight_firewall_*': No such file or directory

      Note:
      If any node in the cluster returns a list of files, this node will be the source of the files in the Resolution section

Environment

VMware Aria Operations for Logs 8.x

Cause

All of the firewall service configuration files have been removed by an unsupported modification to the appliance on at least one node in the cluster.

Resolution

  1. Create snapshots (without memory) of all nodes in the Aria Operations for Logs cluster before making any change.
     
  2. Determine the source node of the replacement loginsight_firewall_*.service files

    • If step 2 in the Issue/Introduction section returned a list of files on any of the nodes in the cluster, use this node as the source node for the files.

    • If step 2 in the Issue/Introduction section errored on all nodes in the cluster, contact Broadcom VCF Support for further assistance.

  3. On all nodes in the cluster that returned errors in Step 2 in the Issue/Introduction section:

    1. Log in to the affected node as root via SSH

    2. scp copy files from the source node. The password required will be the root user password from the source node.

      scp root@source_fqdn_or_ip:/lib/systemd/system/loginsight_firewall_*.service /lib/systemd/system/
      Note: Replace source_fqdn_or_ip with the FQDN or IP of the source node
    3. reload the systemctl unit files

      systemctl daemon-reload
    4. enable the firewall services
      systemctl enable $(find /lib/systemd/system -type f -name "loginsight_firewall_*.service" -printf "%f ")


  4. Power down all the nodes in the Aria Operations for Logs cluster

  5. Power on the primary node and wait until blue Aria Operations for Logs splash screen is seen in vSphere console

  6. Power on all remaining worker nodes

  7. Verify the Aria Operations for Logs UI is available (can take up to 20 minutes after all nodes are powered on)

Additional Information

Broadcom does not support any modifications or customizations to the underlying operating system and packages included in a VMware-branded virtual appliance. Broadcom reserves the right to request all modifications be reverted and that the issue be reproduced on the base release that was originally provided.

For more details, visit VMware Virtual Appliances and customizations to operating system and included packages