Not receiving any fault correlation or root cause analysis alarms

book

Article ID: 36853

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Symptoms: 

Followed the Topology and Root Cause Analysis setup guidelines found on the UIM Wiki page and we can see our topology in the UMP Relationship Viewer portlet.  The net_connect probe was set up to monitor the devices in the topology.  We had an outage, but never received any alarms from the fault_correlation_engine include the root cause analysis alarm.

Environment:  

UIM Server:  8.20
discovery_server:  8.20
discovery_agent:  8.20
topology_agent:  1.69
relationship_services: 1.70
fault_correlation_engine:  1.66
net_connect:  3.20

discovery_agent and topology_agent probes deployed together on multiple remote hubs.

Cause: 

The interface_poller messages generated by the topology_agent probe were not configured to be sent back to the primary hub from the remote hubs where the topology_agent probes are installed.  The fault_correlation_engine probe uses the interface_poller messages to correlate the net_connect alarms in order to generate the appropriate device down or root cause analysis alarms. 

Resolution:

Create a queue to send the interface_poller messages back to the primary hub or add this message to an existing ATTACH queue on the secondary hubs where the topology_agent probes are installed.

Environment

Release: CNMSPP99000-7.6-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component: