Message "No custom attributes defined" under "Attributes" in the DLP incidents
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Message "No custom attributes defined" under "Attributes" in the DLP incidents

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Article ID: 368491

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

The Active Directory Incident Lookup Plugin values are not displayed in the incident attributes.
You only see the message "No custom attributes defined".
The incident history page shows that the lookup was performed and that it grabbed the values.
With the "Custom Attribute Lookup Logging" enabled, the IncidentPersister log shows a successful custom attribute lookup.

Cause

The user role did not have permissions to view the attributes.

Resolution

Once the correct permissions where granted to that role, the custom attribute data was visible in the incident.
Go to System > Login Management > Roles.
Open the appropriate role for editing.
On the General tab, scroll down to "Custom Attributes", select "View All" and, if desired, "Edit All".

Additional Information

See also:

Custom Attributes are not loading automatically even though the plugin works manually

Configuring detailed logging for lookup plug-ins

Once testing is done, restore the default logging:
System > Servers and Detectors > Logs > Configuration tab.
On the Enforce server line, select "Restore Defaults" from the "Diagnostic Logging Settings" dropdown list.
Then click the "Configure Logs" button.