Error occurs while starting 14.5 Workbench
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Error occurs while starting 14.5 Workbench

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Article ID: 368456

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Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

After applying an EFix to the SCM 14.5 full client, opening either Workbench or Administrator Tool results in an error like this:

The .log file contains:

!ENTRY org.eclipse.osgi 4 0 2024-04-30 12:52:58.904
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTException: Invalid thread access

!ENTRY org.eclipse.e4.ui.workbench 4 0 2024-04-30 12:52:58.904
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.eclipse.e4.core.di.InjectionException: java.lang.IllegalStateException: Workbench has not been created yet.

Environment

Harvest SCM v14.5 Full Client

Cause

It was found that the user installing the EFix was not a member of the local Administrator group on the Windows operating system

Resolution

SCM Full Client was uninstalled and reinstalled along with the 14.5 Hot Fix bundle.

Additional Information

More about the 14.5 Hot Fix bundles can be found here: CA Harvest SCM v14.5 - Hot Fixes Availability