LDAP Domain fails to connect to the Active Directory: Server(s) <AD Server>:<Port> not responding
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LDAP Domain fails to connect to the Active Directory: Server(s) <AD Server>:<Port> not responding

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Article ID: 368441

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Updated On:

Products

Automation Analytics & Intelligence

Issue/Introduction

Certificate exception connecting LDAP domain to Active Directory with a pop-up message below.

 Server(s) <Active Directory Server>:<Port> not responding

 

In the jaws.log:

Root exception is javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target]

Environment

Product: Automation Analytics & Intelligence v6.x

Cause

The parameters below are not defined in the file "Automation Analytics & Intelligence (service).exe.vmoptions"

-Djavax.net.ssl.trustStore=<PATH TO STORE>/jawsKeys
-Djavax.net.ssl.trustStorePassword=<PASSWORD>

Resolution

Please make sure that the two parameters below are defined and a valid certificate/password are used.

 

-Djavax.net.ssl.trustStore=<PATH TO STORE>/jawsKeys

-Djavax.net.ssl.trustStorePassword=<PASSWORD>