Integration of the Service Management products fail
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Integration of the Service Management products fail

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Article ID: 368392

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

The following error appears when running the integration of products for 17.4:

Integrations of the products has failed for the below tasks:

Restart CA Service Desk Manager Service.

install.log shows:

INFO  [DeployThread: Integrating the Product(s)] [SDMUtils] command: net start pdm_daemon_manager, Return Code: 2
ERROR [DeployThread: Integrating the Product(s)] [RestartSDMServices] Unable to restart SDM services. Exitcode : 2
ERROR [DeployThread: Integrating the Product(s)] [AutoIntegrateTask] Error occured during intergration task : Unable to restart SDM services. Exitcode : 2

Environment

Service Mangement 17.x

SQL Server 

Cause

missing SQL Server drivers in the SDM server

Resolution

1. Stop and close the installer

2. Install the SQL Server drivers (ODBC, Command Line and Native Client) that are database requirements. Find those drivers in the following link under "SDM SQL Server (2016, 2017, 2019 or 2022) Database Requirements" section.

3. Re-run the installer