Troubleshooting Federated Aria Operations vSphere World object's Data Collection Failure
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Troubleshooting Federated Aria Operations vSphere World object's Data Collection Failure

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Article ID: 368348

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • This article describes a scenario where a Federated Aria Operations instance fails to collect and display data for a specific Aria Operations account in the Environment > Inventory > Object Types > vSphere World section.

Environment

  • Aria Operations 8.x
  • vRealize Operations 8.x

Cause

  • The root cause of the data collection failure was an unhealthy vSphere World object within the Aria Operations instance being monitored. 
  • This object will be in a "Not collecting" state, indicating an issue with the Container Adapter Instance responsible for communication with vCenter.

Resolution

  • Verify vSphere World Object Health:
    • Access the Aria Operations instance experiencing the issue.
    • Navigate to the vSphere World object within the Aria Operations interface from Environment > Inventory > Object Types > vSphere World section.
    • Check if the object is in a healthy state (typically indicated by a green Check (✔︎) mark).

 

  • Restart Container Adapter Instance:
    • If the vSphere World object is unhealthy, Restart the Container Adapter Instance within the Aria Operations instance.
    • This can be done from the Environment > Inventory > Adapter Instance > Container section. (As shown in the Screenshot below)

 

E.g. of Non-Working vSphere World object:

 

E.g. of Working vSphere World object:

Additional Information

  • Ensure proper configuration and connectivity between the Federated Aria Operations and Aggregated Aria Operations instances.
  • Verify that the Aggregator Adapter version is compatible with the Aria Operations version.
  • Taking snapshots before performing upgrades on Aria Operations is highly recommended.