Full Inventory is not removing entries from software installed reports after software removal from Users profiles
search cancel

Full Inventory is not removing entries from software installed reports after software removal from Users profiles

book

Article ID: 368292

calendar_today

Updated On:

Products

IT Management Suite Inventory Solution

Issue/Introduction

Full inventory is not deleting/removing references from the software installed reports after such software has been uninstalled/removal from some Users profiles on client machines.
You have verified that the software file is no longer in "user app data" (C:\Users\<User>\AppData) directory.
You also confirmed that when you go to "Add Remove Programs" that this software does not show up there.
After running a full inventory, Applications still shows in the Add Remove reports as present.  Even after user profile deletions.

Environment

ITMS 8.6, 8.7

Cause

Enhancement Request.

Briefly speaking, this is the current behaviour during a Full Inventory for this Use Case:

  • If software was detected as installed (from the private user hive), when the user private hive was loaded, then we DO NOT mark it as uninstalled at the point the registry hive is NOT loaded during the scan.
  • In ITMS 8.7.2 release and before, the ITMS product did not load forcibly all the unloaded HKEY_USERS registry hives to scan them explicitly.

Resolution

A few changes to how this is handled were made in the ITMS 8.73 Release. 

A workaround for this problem can be attempted to clear out those outdated references by doing the following:

  • Remove the SoftwareCache_v2.xml (C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\data\SoftwareCache_v2.xml) on the client machine(s)
  • Re-run a full Software Inventory scan again so the most recent references are sent.