CMDB Visualizer Error: Unable to perform specified action
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CMDB Visualizer Error: Unable to perform specified action

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Article ID: 368202

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When attempting to view any graph within CMDB Visualizer, following error is received:

Environment

CA Service Desk Manager 17.3 RU1 and higher

All Supported Operating Systems

Cause

Data corruption in MDB table ca_cmpny (SQL Table name: ca_company)

Resolution

After enabling debug tracing for CMDB Visualizer, entries similar to the following are seen in the visualizerMS_debug.log file :

DEBUG - [com.ca.casm.sdm.SdmProducerUtil] - For (ca_cmpny) working on Majic attribute: sym
DEBUG - [com.ca.casm.sdm.SdmProducerUtil] - Attribute value is null, skipping...

These errors indicate that there are entries where sym name (column name in SQL is: company_name) is null or not present even though it is a REQUIRED field.

Must update the entries for which sym name is null to some random name via a direct SQL query.

After fixing the missing data, either restart the SDM Service or the Visualizer Tomcat process.