LDAP Error 52 (password) during startup steps--cannot connect to user store.
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LDAP Error 52 (password) during startup steps--cannot connect to user store.

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Article ID: 368148

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Identity Manager Environment fails to start throwing ldap error 52 (incorrect password value) when attempting connection to the user directory.

The password needs to be updated in Identity Manager. If you can access the management console, export the directory.xml update the user directory's credentias, and re-import the directory.xml. But without the environment starting up there is no access to the immanage console for exporting/importing a revised password.

Environment

All versions.

Cause

The password on the user directory has been changed on the directory itself, but now needs to be updated in Identity Manager. 

Since Identity Manager does not fully start up, there is no access available yet to the Management Console.

The environment's user store credentials that would normally be available to update by exporting/importing via the directory.xml in the console are also stored in the IDM Object Store database.

Working with your DBA, as needed, you can update the user and/or password in the object store table [dbo].[IM_DIR_CONNECTION]. You should see a row for your user store.

Resolution

Working with your DBA, as needed, you can update the user and/or password in the object store table [dbo].[IM_DIR_CONNECTION]. You should see a row for your user store, for example,

 

Note: the password is encrypted. If you do not know the password's encrypted value, use the Password Tool provided in the Identity Manager installation location /tools directory, <IM_HOME>\IAM Suite\Identity Manager\tools\PasswordTool, to encrypt the password.

Once the user credentials are updated with the new values the next startup should successfully connect to the user store.