System cannot find file during processing
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System cannot find file during processing

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Article ID: 368076

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Updated On: 06-18-2025

Products

Information Centric Analytics

Issue/Introduction

One or more of the following steps of the nightly RiskFabric Processing job fail (step IDs for versions up to 6.6 MP2 are noted parenthetically):

  • Metric Collector (22)
  • Update DB Utility Versions (23)
  • Send License Expiration Notifications (25)
  • Send Scenario Step Up Emails (26)
  • Send Email Notifications (27)

NOTE: Additional job steps were introduced with ICA 6.7; consequently, job step IDs for that version will differ from those listed above. The job step IDs for 6.7 are:

  • Metric Collector (24)
  • Update DB Utility Versions (25)
  • Send License Expiration Notifications (27)
  • Send Scenario Step Up Emails (28)
  • Send Email Notifications (29)

One or more of the following corresponding errors are captured in the SQL Server Agent history log:

Executed as user: [<domain>\]<account>. The process could not be created for step 22 of job 0x08792F55D0A7C1488FF33273CF89270D (reason: The system cannot find the file specified).  The step failed.
Executed as user: [<domain>\]<account>. The process could not be created for step 23 of job 0x08792F55D0A7C1488FF33273CF89270D (reason: The system cannot find the file specified).  The step failed.
Executed as user: [<domain>\]<account>. The process could not be created for step 25 of job 0x08792F55D0A7C1488FF33273CF89270D (reason: The system cannot find the file specified).  The step failed.
Executed as user: [<domain>\]<account>. The process could not be created for step 26 of job 0x08792F55D0A7C1488FF33273CF89270D (reason: The system cannot find the file specified).  The step failed.
Executed as user: [<domain>\]<account>. The process could not be created for step 27 of job 0x08792F55D0A7C1488FF33273CF89270D (reason: The system cannot find the file specified).  The step failed.

In some cases, if you edit the properties of the RiskFabric Processing job to view a failing step's configuration, you find the path contains a partial path followed by the correct path. For example:

\Bay Dynamics\Database Utilities\ "C:\Program Files\Bay Dynamics\Database Utilities\[...]"

Environment

Version : 6.x

Component : Database Utilities

Cause

The path to the command specified in the failing RiskFabric Processing job step is malformed, incomplete, or points to a location that does not exist on the filesystem.

Resolution

The value of of the portal setting Path to Database Utilities in the Risk Fabric console defines the root path to be used by job steps of the type Operating system (CmdExec). You should confirm that value is correct prior to following the remaining procedures in this article. To check this setting, either navigate in the console to Admin > Settings > General > Advanced Settings > Path to Database Utilities, or execute the following query in SQL Server Management Studio (SSMS):

  1. Open SSMS
  2. Connect to the Database Engine hosting the RiskFabric relational database
  3. From the File menu, select New > Query with Current Connection
    A new query editor window opens
  4. Copy the following query and paste it in the new query editor window:
    SELECT [Value] FROM RiskFabric.dbo.PortalSettings WHERE [Name] = N'DatabaseUtilitiesFolderPath';
  5. Execute the query by pressing the F5 key, clicking the Execute button in the SQL Editor toolbar, or selecting Execute from the Query menu
  6. Record the path for comparison with the output of the next procedure

Next, identify the base path(s) specified in the failing job step(s) by following this procedure in SSMS:

  1. From the File menu, select New > Query with Current Connection
    A new query editor window opens
  2. Copy the following query and paste it in the new query editor window:
    USE msdb;
    GO

    SELECT     js.step_id,
               js.step_name,
               js.command
    FROM       dbo.sysjobsteps AS js
    INNER JOIN dbo.sysjobs AS j
            ON js.job_id = j.job_id
    WHERE      j.[name] = N'RiskFabric Processing' AND
               js.subsystem = N'CmdExec';
  3. Execute the query by pressing the F5 key, clicking the Execute button in the SQL Editor toolbar, or selecting Execute from the Query menu
  4. Compare the base paths output by this query with the Path to Database Utilities value

If the base path(s) correctly correspond to the Path to Database Utilities value, determine whether the path(s) returned in the command column for each failing job step exist on the filesystem. If one or more executables are missing from the Database Utilities path, the Database Utilities may not have been installed correctly. If that is true, reinstall the Database Utilities using the Symantec Information Centric Analytics (ICA) Installation Wizard.

If the utilities exist in the correct location but the path specified in the job step command is malformed or incorrect, modify the command path in the job step by following this procedure in SSMS:

  1. In Object Explorer, navigate to SQL Server Agent > Jobs
  2. Right-click the RiskFabric Processing job and select Properties
    The Job Properties - RiskFabric Processing window opens
  3. Select the Steps page
  4. Select the failing job step and click the Edit button
    The Job Step Properties - <step-name> window opens
  5. Modify the path to the executable provided in the Command window
    NOTE: paths containing spaces should be enclosed in double-quotation marks ("), as in the following example:
    "E:\Program Files\Bay Dynamics\Database Utilities\TaskRunner\TaskRunner.exe" TaskRunner.Tasks.Custom.DBUtilitiesVersionUpdater
  6. Click the OK button to close the Job Step Properties - <step-name> window
  7. Repeat steps 6 through 8 for each step that is failing
  8. Click the OK button to close the Job Properties - RiskFabric Processing window