Spectrumgtw probe is no longer syncing Spectrum alarms to UIM
search cancel

Spectrumgtw probe is no longer syncing Spectrum alarms to UIM

book

Article ID: 368048

calendar_today

Updated On:

Products

DX NetOps CA Spectrum DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Since a few days ago the spectrumgtw probe stopped syncing alarm from Spectrum to UIM (bi-directional alarm sync is not enable). The spectrumgtw probe has been restarted and also cleared the probe's cache directory.

These repeated lines are found in the spectrumgtw.log file:

2024-05-08 10:41:35,864 ERROR SpectrumGtwScheduler_Worker-9: [SpectrumGtwRestRespHandler] [spectrumGtwRestRespExceptionHandler] - Null keys are not supported!

Environment

Spectrum 23.3.4 - UIM 20.4 CU6 and spectrumgtw 20.40

Cause

There is an UIM generated alarms without an alarm ID. 

It is failing here: if (UimAlarmsCache.getCache().containsKey(uimAlarm.getAlarmId())

That means one or more of the UIM alarm(s) do(es) not have alarm ID(s). That means it has null ID, giving this error:
java.lang.NullPointerException: Null keys are not supported!

2024-05-16 15:44:38,972 ERROR SpectrumGtwScheduler_Worker-3: [AlarmProcessingController] [startAlarmProcessing] - Catching
java.lang.NullPointerException: Null keys are not supported!

Resolution

Search in the UIM alarms, in the nas_alarms table and delete the alarm without alarm ID. Then deactivate and activate the spectrumgtw probe. 

select * from nas_alarms order by nimid asc

delete from nas_alarms where nimid is NULL