PII Audit Filtering
search cancel

PII Audit Filtering

book

Article ID: 367989

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When using filters for our PII Audit Scans on SQL Server tables, the filters do not work. The Include filters are not scanning any tables, and the Exclude filters are scanning all tables. We are not seeing this issue for our Oracle database tables.

Environment

TDM Portal 4.10

Cause

In order for the filter to find a match, all three fields of the filter configuration must find a match:

  • Connection Profile Name
  • Schema Name
  • Table Name

In the configuration, if we use the database name inside the Schema field for the filters, this will cause the filter to not find a match.

As a result:

  • The Include filters do not find any tables to include in the scan, therefore no tables are scanned.
  • The Exclude filters do not find any tables to exclude from the scan, therefore all tables are scanned

For example:

Connection Profile in TDM Portal:

Filter Configuration:

Scan Results for Include Filter:

Scan Results for Exclude Filter:

Resolution

To resolve this, please modify the Filter configuration, and ensure the Connection Profile name matches the Profile name found in TDM Portal, and use the proper Schema name for the profile connection.

In this example, we should use dbo as the Schema name instead of the database name.

Additional Information

Note: this typically is not an issue for Oracle databases, since the database name and schema name are normally the same.