Predecessor and Successor Issue Link types do not show up in ConnectALL
search cancel

Predecessor and Successor Issue Link types do not show up in ConnectALL

book

Article ID: 367968

calendar_today

Updated On:

Products

ConnectAll On-Prem ConnectALL ConnectAll SaaS

Issue/Introduction

Issue Link mappings in ConnectALL for Rally Portfolio Item Predecessors and Successors are not available in the dropdown.

 

Environment

Rally Adapter v1 on the following ConnectALL versions:

  • 2.11
  • 3.0
  • 3.1
  • 3.2
  • 3.3

Cause

This can be caused if the default Rally Portfolio Item has been renamed from Feature to another name.

Resolution

In the examples below, we will use "Epic" as our custom portfolio item name, so it will be necessary to change that to the value you have chosen.

Update Connection

In order to get “Predecessor”, “Successor” relationship in the dropdown for Issue Links it will first be necessary to add a connection property.  

  1. Navigate to Connections page
  2. Choose the Rally connection
  3. Click on the Gear icon to open up the properties window
  4. Add a property called ISSUE_LINKTYPE with value PortfolioItem/Epic

 

Update Automation

Next update the automation to contain the issue link mappings.

  1. Navigate to the Automations page
  2. Choose your Portfolio Item automation
  3. Click the Modify icon to open up the config
  4. Add the Issue Link fields to your mappings, if you have not already done so
  5. Modify the Value Mappings to link your other system's issue type to the Rally Dependencies
  6. Click Save Mappings
  7. Click the Chain icon for the Issue Link mappings and hover your mouse over portfolioitem to verify that the Type is correct (Epic, in this example)
  8. If it is not correct and it shows the default Portfolio Item type, modify the mapping again
  9. Click Export
  10. Open the CSV in an editor
  11. Replace Feature with the actual name of your portfolio item type name (Epic, in this example)
  12. Save the CSV
  13. Go back to the ConnectALL value mapping
  14. Click Import
  15. Choose the CSV file
  16. Click OK to close the dialog popup
  17. Close the Value Mapping screen (Do not click Save Mappings)
  18. Click the Chain icon for the Issue Link mappings and hover your mouse over portfolioitem to verify that the Type is correct (Epic, in this example)