Powering on backup Proxy virtual machine fails with 'Unable to access file since it is locked'
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Powering on backup Proxy virtual machine fails with 'Unable to access file since it is locked'

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Article ID: 367921

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • When powering on a backup proxy VM an error message is displayed of 'Unable to access file since it is locked.'
  • Backup proxy VM (Veeam, Avamar, Unitrends,...etc) is locking one or more of the virtual machine .vmdk files.

Environment

VMware vSphere ESXi 8.x
VMware vSphere ESXi 7.x

Cause

Backup proxy VM does not unmount vmdk files after the backup job has completed.

Resolution

If the VM is in an inaccessible state unregister the VM and register again and then perform the following steps before attempting to power on the VM

  1. Right click on the VM go to edit settings
  2. Verify that the VM has its own vmdk files
  3. Verify that there are vmdk files from other VMs attached to it
  4. On the right side of the hard drive line click on the X icon, See Deleting a vmdk file for a virtual machine that is no longer used fails: Device or resource busy
  5. Verify that the delete from datastore checkbox is unchecked
  6. Repeat the process for any additional VMDK files not owned by the VM
  7. Click ok

Additional Information