API Plan and Rate Limits & Quotas sync failing
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API Plan and Rate Limits & Quotas sync failing

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Article ID: 367894

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

After upgrading and re-enrolling the gateway to the portal, the ssg log showed sync issues. 

2024-05-15T11:30:00.067-0400 INFO    329  com.l7tech.server.policy.assertion.ServerAuditDetailAssertion: -4: Portal API sync status : no updates from portal
2024-05-15T11:30:00.076-0400 INFO    327  com.l7tech.server.policy.assertion.ServerAuditDetailAssertion: -4: No Api Plans Sync Response
2024-05-15T11:30:00.077-0400 INFO    323  com.l7tech.server.policy.assertion.ServerAuditDetailAssertion: -4: Empty Account Plans Sync Response

Environment

API Gateway 11.1
API Portal 5.2.3 (on-prem)

Cause

After re-enrolling an existing gateway to a known portal, it may be necessary to force the syncing of the Rate Limits & API Plans. 

Resolution

You can force a sync by editing any Organization-level Rate Limit & Quota and clicking Save without making any changes.

Additional Information

To check which ssg log has the portal sync information, you need to confirm which gateway node is the master node in your cluster. If there is a single gateway node, skip this step.  

   > Login to MySQL 
   > Run the following command: select * from cluster_master;
   > Make note of the node_id
   > Run the following command: select * from cluster_info;
   > Identify which gateway has the same node_id from the previous command - this will be the node all ssg logs will need to come from because all portal syncs will appear in these logs.

Tail the ssg log with filter/grep of "deployer" on the master node (identified in the above step)